输入您的问题查找答案
   
 
相关文库文档
更多相关文库文档 >>
联系客服
在线技术支持
客户服务热线:

电话销售热线:

服务时间(法定节假日除外):
家庭产品:
周一~周五:8:30~20:30
周六:9:00~18:00
商用产品:
周一~周五:8:30~18:30
周六:9:00~18:00
广东话支持:
周一~周五:9:00~12:00;13:00~18:00
商用网络动态

与 NETGEAR 监控专用交换机亲密接触

选择德才兼备的 PoE 交换机

NETGEAR 交换机助力聊城第二人民医院智能监控建设

更多动态 >>

网件文库 » 交换机产品  »  配置NETGEAR交换机的802.1 Q in Q(double VLAN)功能
配置NETGEAR交换机的802.1 Q in Q(double VLAN)功能

编号:30159       来自:NetGear       更新日期:2012-03-21       访问数量:7681

一、Q-in-Q技术的历史介绍:

IEEE 802.1Q分组标记是一种描述城域网中客户流量的方法,IEEE 802.1Q标准规定了:包括封装内容以及在以后的一些内容;例如:生成树的增强、GARP和802.1P QOS标记等。802.1Q帧格式保留了原来的以太网的帧格式,在城域网中使用IEEE802.1Q的状况下,因为客户端的网络可能会使IEEE 802.1Q标记来描述VLAN或用802.1P用户优先级来描述QOS,IEEE 802.1Q标记的长度是4个字节,对于包含单个IEEE 802.1Q标记帧,它的最大尺寸是1522字节,所以城域网交换机必须支持小巨型帧。IEEE 802.1Q的主要优点在于低成本和点到多点的工作方式,缺点在于企业仍然共享相同的核心网络。企业流量和网络流量之间没有实现真正的隔离。例如:某个企业的运行可能会影响到其它企业。

在802.1Q的优点基础之上,城域以太网的第二种封装选项是802.1Q隧道,通过对进入的流量增加额外的标识,Q-in-Q隧道能够隔离企业的流量,进而将每个企业的流量与服务商VLAN进行隔离,在标准的IEEE 802.1Q中,企业网络之间不能使用重叠的VLAN-ID。例如:图1 

图1

企业A和企业B使用重叠的VLAN-ID,如果不能使用802.1Q隧道,那么这种拓扑就会发生冲突,然而在采用802.1Q隧道的情况之下VLAN-ID可以重叠,其原因在于服务商Q-in-Q封装仅在城域网解决方案的局部产生作用。

通过将每个站点的VLAN进行隧道处理,使其位于服务商网络中新的特定VLAN中,企业网络的VLAN标识就进入透明状态。例如:图2

图2

在这种解决方案中,Q-in-Q需要使用额外的802.1Q标记,它可以通过城域网对企业A的流量和企业B的流量进行隔离。

当帧从链路的一端到另一端的时候,交换机将在多个位子增加或解除802.1Q标记。在帧进入企业网络之前,企业网络的边界路由器或交换机将增加802.1Q标记来标识客户的VLAN。服务提供商网络在入口处增加额外的802.1Q标记来标识服务提供商的VLAN,从而提供Q-in-Q隧道。

二、NETGEAR交换机QinQ配置介绍

2.1 网络拓扑:

以FSM7352S为核心,假设2台FSM7250RS为汇聚,FSM7226RS为接入。

FSM7352S第一口接Server,第48口接FSM7250RS(1)的48口.

FSM7250RS(1)第一口与FSM7250RS(2)的第一口连接,第48口连接FSM7352S的48口。

FSM7250RS(2)第一口与FSM7250RS(1)的第一口连接,第48口连接FSM7226RS的24口。

FSM7226RS第一口连接Client PC,第24口连接FSM7250RS(2)的48口。

2.2 配置目标

接入层交换机上有多个VLAN,经过汇聚的QinQ后与核心交换机上相应VLAN连通。

2.3 交换机配置

2.3.1 FSM7352S配置

(FSM7352S) #show running-config changed

!Current Configuration:

!

!System Description "FSM7352S 48+4 L3 Stackable Switch"

!System Description 7.3.3.3

!

set prompt "FSM7352S"

vlan database

vlan10

vlan20

vlan30

vlan routing 30

vlan routing 20

vlan routing 10

exit

 

configure

sntp client mode unicast

! sntp server status is active

sntp server time-d.netgear.com

stack

exit

 

logging buffered

slot 1/0 2

set slot power 1/0

no set slot disable 1/0

ip routing

lineconfig

exit

 

spanning-tree configuration name 00-14-6C-0B-00-46

snmp-server community public@10

snmp-server community public@20

snmp-server community public@30

interface1/0/1

vlan pvid 10

vlan participation include 10

exit

 

interface1/0/2

vlan pvid 20

vlan participation include 20

exit

 

interface1/0/3

vlan pvid 30

vlan participation include 30

exit

 

interface1/0/48

vlan participation include 10

vlan tagging 10

vlan participation include 20

vlan tagging 20

vlan participation include 30

vlan tagging 30

exit

 

interface vlan 30

routing

ip address172.16.30.1255.255.255.0

exit

 

interface vlan 20

routing

ip address172.16.20.1255.255.255.0

exit

 

interface vlan 10

routing

ip address172.16.10.1255.255.255.0

exit

 

service dhcp

ip dhcp pool v10

dns-server 192.168.1.1

default-router 172.16.10.1

network 172.16.10.0 255.255.255.0

exit

 

ip dhcp pool v20

dns-server 192.168.1.1

default-router 172.16.20.1

network 172.16.20.0 255.255.255.0

exit

 

ip dhcp pool v30

dns-server 192.168.1.1

default-router 172.16.30.1

network 172.16.30.0 255.255.255.0

exit

 

exit

2.3.2 FSM7250RS(1)与FSM7250RS(2)的配置,因为使用相同的端口,因此两台配置相同。

(FSM7250RS) #show running-config changed

!Current Configuration:

!

!System Description "FSM7250RS ProSafe 48-port 10/100 L2 Managed Stackable Switch with Static Routing"

!System Description 7.3.2.1

!

set prompt "FSM7250RS"

network protocol none

vlan database

vlan100

exit

 

configure

sntp client mode unicast

! sntp server status is active

sntp server time-d.netgear.com

stack

exit

 

logging buffered

slot 1/0 6

set slot power 1/0

no set slot disable 1/0

lineconfig

exit

 

spanning-tree configuration name 00-1E-2A-C6-0B-70

snmp-server community public@100

interface1/0/1

vlan participation include 100

vlan tagging 100

mode dvlan-tunnel

exit

 

interface1/0/48

vlan pvid 100

vlan participation include 100

exit

 

exit

2.3.3 FSM7226RS的配置

(FSM7226RS) #show running-config changed

!Current Configuration:

!

!System Description "FSM7226RS ProSafe 24-port 10/100 L2 Managed Stackable Switch with Static Routing"

!System Description 7.3.2.1

!

set prompt "FSM7226RS"

network protocol none

vlan database

vlan10

vlan20

vlan30

exit

 

configure

sntp client mode unicast

! sntp server status is active

sntp server time-d.netgear.com

stack

exit

 

logging buffered

slot 1/0 5

set slot power 1/0

no set slot disable 1/0

lineconfig

exit

 

spanning-tree configuration name 00-1E-2A-C6-06-04

snmp-server community public@10

snmp-server community public@20

snmp-server community public@30

interface1/0/1

vlan pvid 10

vlan participation include 10

exit

 

interface1/0/2

vlan pvid 20

vlan participation include 20

exit

 

interface1/0/3

vlan pvid 30

vlan participation include 30

exit

 

interface1/0/24

vlan participation include 10

vlan tagging 10

vlan participation include 20

vlan tagging 20

vlan participation include 30

vlan tagging 30

exit

 

exit

2.4 测试结果

从FSM7226RS的1,2,3端口接client PC,可以从FSM7352S上获得IP地址,并与Server连通。

 

序号 no.

日期 date

作者 author

摘要 summary

1

2010-11-04

Netgear

文档创建

  
 
以上内容是否为您所需要的答案?
以上内容是否清晰、简明和易于理解的?
您是如何知道网件社区的?